$re = '/\b(\d+)\b/';
$str = '"18775551234"
"person" <5551234>, "text, might match an email" <foo@bar.com>
"SomeText"
"18775551234", "SomeText", "foo@bar.com" <foo@bar.com>
"foo@bar.com"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);