use strict;
my $str = '"18775551234"
"person" <5551234>, "text, might match an email" <foo@bar.com>
"SomeText"
"18775551234", "SomeText", "foo@bar.com" <foo@bar.com>
"foo@bar.com"';
my $regex = qr/\b(\d+)\b/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}