const regex = /\b(\d+)\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)\\b', '')
const str = `"18775551234"
"person" <5551234>, "text, might match an email" <foo@bar.com>
"SomeText"
"18775551234", "SomeText", "foo@bar.com" <foo@bar.com>
"foo@bar.com"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}