#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(\d+)\b"
Local $sString = ""18775551234"" & @CRLF & _
""person" <5551234>, "text, might match an email" <foo@bar.com>" & @CRLF & _
""SomeText"" & @CRLF & _
""18775551234", "SomeText", "foo@bar.com" <foo@bar.com>" & @CRLF & _
""foo@bar.com""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")