re = /market\/report\S+(?:\.cpp|\.h)\b/
str = 'test.cpp
test.h
test.html
market/report/test.cpp
market/report/src/t2.cpp
not/market/report/a.cpp
market/library/t.h
market.cpp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end