package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`market\/report\S+(?:\.cpp|\.h)\b`)
var str = `test.cpp
test.h
test.html
market/report/test.cpp
market/report/src/t2.cpp
not/market/report/a.cpp
market/library/t.h
market.cpp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}