using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"market\/report\S+(?:\.cpp|\.h)\b";
string input = @"test.cpp
test.h
test.html
market/report/test.cpp
market/report/src/t2.cpp
not/market/report/a.cpp
market/library/t.h
market.cpp";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}