use strict;
my $str = 'test.cpp
test.h
test.html
market/report/test.cpp
market/report/src/t2.cpp
not/market/report/a.cpp
market/library/t.h
market.cpp';
my $regex = qr/market\/report\S+(?:\.cpp|\.h)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}