$re = '/market\/report\S+(?:\.cpp|\.h)\b/';
$str = 'test.cpp
test.h
test.html
market/report/test.cpp
market/report/src/t2.cpp
not/market/report/a.cpp
market/library/t.h
market.cpp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);