// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<AUDT:INFO>.* Passwordstate:").unwrap();
let string = "08 21 2020 08:15:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:14:25 10.72.1.17 Passwordstate: Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host 'fakeserver.fakedomain.tld' using the manual credentials of 'FakeUser'.Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host 'fakeserver.fakedomain.tld' using the manual credentials of 'FakeUser'. Reason = Task 31117 Checking GPT files Client IP Address = 10.14.72.232";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}