import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<AUDT:INFO>.* Passwordstate:";
final String string = "08 21 2020 08:15:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:14:25 10.72.1.17 Passwordstate: Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host 'fakeserver.fakedomain.tld' using the manual credentials of 'FakeUser'.Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host 'fakeserver.fakedomain.tld' using the manual credentials of 'FakeUser'. Reason = Task 31117 Checking GPT files Client IP Address = 10.14.72.232";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}