# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<AUDT:INFO>.* Passwordstate:"
test_str = "08 21 2020 08:15:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:14:25 10.72.1.17 Passwordstate: Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host 'fakeserver.fakedomain.tld' using the manual credentials of 'FakeUser'.Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host 'fakeserver.fakedomain.tld' using the manual credentials of 'FakeUser'. Reason = Task 31117 Checking GPT files Client IP Address = 10.14.72.232"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.