use strict;
my $str = '08 21 2020 08:15:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:14:25 10.72.1.17 Passwordstate: Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host \'fakeserver.fakedomain.tld\' using the manual credentials of \'FakeUser\'.Fake User (fakedoamin\\FakeUser) initiated a Remote Session connection to Host \'fakeserver.fakedomain.tld\' using the manual credentials of \'FakeUser\'. Reason = Task 31117 Checking GPT files Client IP Address = 10.14.72.232';
my $regex = qr/<AUDT:INFO>.* Passwordstate:/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}