import Foundation
let pattern = #"""
.*?storagegroup:100\|Storage Group space used\|.*|.*?cn1=(7[6-9]|8[0-9]|9[0-9]|100).*
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" (storagegroup:100 AND deviceCustomerNumber 1 > 75)_storageGroup IN ["Internal Event Storage Group"]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}