$re = '/.*?storagegroup:100\|Storage Group space used\|.*|.*?cn1=(7[6-9]|8[0-9]|9[0-9]|100).*
/';
$str = ' (storagegroup:100 AND deviceCustomerNumber 1 > 75)_storageGroup IN ["Internal Event Storage Group"]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);