const regex = /.*?storagegroup:100\|Storage Group space used\|.*|.*?cn1=(7[6-9]|8[0-9]|9[0-9]|100).*
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?storagegroup:100\\|Storage Group space used\\|.*|.*?cn1=(7[6-9]|8[0-9]|9[0-9]|100).*
', '')
const str = ` (storagegroup:100 AND deviceCustomerNumber 1 > 75)_storageGroup IN ["Internal Event Storage Group"]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}