package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?storagegroup:100\|Storage Group space used\|.*|.*?cn1=(7[6-9]|8[0-9]|9[0-9]|100).*
`)
var str = ` (storagegroup:100 AND deviceCustomerNumber 1 > 75)_storageGroup IN ["Internal Event Storage Group"]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}