import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?storagegroup:100\\|Storage Group space used\\|.*|.*?cn1=(7[6-9]|8[0-9]|9[0-9]|100).*\n";
final String string = " (storagegroup:100 AND deviceCustomerNumber 1 > 75)_storageGroup IN [\"Internal Event Storage Group\"]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}