// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\w\.]+@[a-zA-Z_]+?(\.[a-zA-Z]{2,6})+").unwrap();
let string = "// Valid
mail@mail.ru
mail.mail@mail.ru
mail@mail.mail.ru
// Invalid
@.ru
@mail.ru
mail.ru
mail@mail
mail@mail.mail.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}