import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w\\.]+@[a-zA-Z_]+?(\\.[a-zA-Z]{2,6})+";
final String string = "// Valid\n"
+ "mail@mail.ru\n"
+ "mail.mail@mail.ru\n"
+ "mail@mail.mail.ru\n\n"
+ "// Invalid\n"
+ "@.ru\n"
+ "@mail.ru\n"
+ "mail.ru\n"
+ "mail@mail\n"
+ "mail@mail.mail.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}