re = /[\w\.]+@[a-zA-Z_]+?(\.[a-zA-Z]{2,6})+/
str = '// Valid
mail@mail.ru
mail.mail@mail.ru
mail@mail.mail.ru
// Invalid
@.ru
@mail.ru
mail.ru
mail@mail
mail@mail.mail.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end