using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w\.]+@[a-zA-Z_]+?(\.[a-zA-Z]{2,6})+";
string input = @"// Valid
mail@mail.ru
mail.mail@mail.ru
mail@mail.mail.ru
// Invalid
@.ru
@mail.ru
mail.ru
mail@mail
mail@mail.mail.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}