$re = '/[\w\.]+@[a-zA-Z_]+?(\.[a-zA-Z]{2,6})+/';
$str = '// Valid
mail@mail.ru
mail.mail@mail.ru
mail@mail.mail.ru
// Invalid
@.ru
@mail.ru
mail.ru
mail@mail
mail@mail.mail.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);