// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\$(\d{1,3}[\.,]*)+").unwrap();
let string = "$5.34
$5,34
$222,100,455.34
$222.100.455,34
$222,100,455
$222.100.455
$4,13 + $5,24 = $9,37
$4,13 + $1.005,24 = $1.009,37
$8.000 - $8.000 = $0
$4.545,45 is less than $5,454.54.
$4,545.45 is less than $5.454,54.
Our movie tickets cost $12,20.
127.255.255.255
Clayton Kershaw $31.000.000
Zack Greinke $27.000.000
Adrian Gonzalez $21.857.143
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}