# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$(\d{1,3}[\.,]*)+"
test_str = ("$5.34\n"
"$5,34\n"
"$222,100,455.34\n"
"$222.100.455,34\n\n"
"$222,100,455\n"
"$222.100.455\n\n"
"$4,13 + $5,24 = $9,37\n"
"$4,13 + $1.005,24 = $1.009,37\n"
"$8.000 - $8.000 = $0\n\n"
"$4.545,45 is less than $5,454.54.\n"
"$4,545.45 is less than $5.454,54.\n"
"Our movie tickets cost $12,20.\n\n"
"127.255.255.255\n\n"
"Clayton Kershaw $31.000.000\n"
"Zack Greinke $27.000.000\n"
"Adrian Gonzalez $21.857.143\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.