package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$(\d{1,3}[\.,]*)+`)
var str = `$5.34
$5,34
$222,100,455.34
$222.100.455,34
$222,100,455
$222.100.455
$4,13 + $5,24 = $9,37
$4,13 + $1.005,24 = $1.009,37
$8.000 - $8.000 = $0
$4.545,45 is less than $5,454.54.
$4,545.45 is less than $5.454,54.
Our movie tickets cost $12,20.
127.255.255.255
Clayton Kershaw $31.000.000
Zack Greinke $27.000.000
Adrian Gonzalez $21.857.143
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}