use strict;
my $str = '$5.34
$5,34
$222,100,455.34
$222.100.455,34
$222,100,455
$222.100.455
$4,13 + $5,24 = $9,37
$4,13 + $1.005,24 = $1.009,37
$8.000 - $8.000 = $0
$4.545,45 is less than $5,454.54.
$4,545.45 is less than $5.454,54.
Our movie tickets cost $12,20.
127.255.255.255
Clayton Kershaw $31.000.000
Zack Greinke $27.000.000
Adrian Gonzalez $21.857.143
';
my $regex = qr/\$(\d{1,3}[\.,]*)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}