using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(\d{1,3}[\.,]*)+";
string input = @"$5.34
$5,34
$222,100,455.34
$222.100.455,34
$222,100,455
$222.100.455
$4,13 + $5,24 = $9,37
$4,13 + $1.005,24 = $1.009,37
$8.000 - $8.000 = $0
$4.545,45 is less than $5,454.54.
$4,545.45 is less than $5.454,54.
Our movie tickets cost $12,20.
127.255.255.255
Clayton Kershaw $31.000.000
Zack Greinke $27.000.000
Adrian Gonzalez $21.857.143
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}