import Foundation
let pattern = #"(\w)(\w*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Pig latin is cool !"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2$1ay"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)