use strict;
my $str = 'Pig latin is cool !';
my $regex = qr/(\w)(\w*)/mp;
my $subst = '$2$1ay';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";