$re = '/(\w)(\w*)/m';
$str = 'Pig latin is cool !';
$subst = "$2$1ay";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;