package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w)(\w*)`)
var str = `Pig latin is cool !`
var substitution = "$2$1ay"
fmt.Println(re.ReplaceAllString(str, substitution))
}