# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w)(\w*)/$2$1ay/gm;t' <<< "Pig latin is cool !"