use strict;
my $str = 'Vit5
V.it
.Vit
Vit.
Vit\\\\
V|it
Vi-t
V+it
+Vit
Vit^
V^it
V&it
Vi#t
Vi@t
Vit
Vit
V it
Vi)t
V(it
Vi[t
Vi]t
V?it
V!it
V$it
V*it
Vi{t
Vi}t
V<it
Vi>t
Vi_t
V-it
Vi=t
Vi%t
ˇVit
V;it
V\\"it
V\'it
V§t
V¨t
V`t
Dopita
Václav
Átos
Čeněk
Pačáp
Ďurica
Naďa
Rémi
Zdeněk
Vít
Ľudovít
Ňouma
Ňuňu
Lórenc
Ópava
Mótovidlo
Řeřicha
Šušinka
Ťaťak
Úlehlú
Ůlehlů
Ýtý
Žežulka';
my $regex = qr/^((?![0-9.,!?:;_|+\-*\\/=%°@&#§$"'`¨^ˇ()\[\]<>{}])[\S])+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}