const regex = /^((?![0-9.,!?:;_|+\-*\\/=%°@&#§$"'`¨^ˇ()\[\]<>{}])[\S])+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?![0-9.,!?:;_|+\\-*\\\\\/=%°@&#§$"\'`¨^ˇ()\\[\\]<>{}])[\\S])+$', 'gm')
const str = `Vit5
V.it
.Vit
Vit.
Vit\\\\
V|it
Vi-t
V+it
+Vit
Vit^
V^it
V&it
Vi#t
Vi@t
Vit
Vit
V it
Vi)t
V(it
Vi[t
Vi]t
V?it
V!it
V\$it
V*it
Vi{t
Vi}t
V<it
Vi>t
Vi_t
V-it
Vi=t
Vi%t
ˇVit
V;it
V\\"it
V'it
V§t
V¨t
V\`t
Dopita
Václav
Átos
Čeněk
Pačáp
Ďurica
Naďa
Rémi
Zdeněk
Vít
Ľudovít
Ňouma
Ňuňu
Lórenc
Ópava
Mótovidlo
Řeřicha
Šušinka
Ťaťak
Úlehlú
Ůlehlů
Ýtý
Žežulka`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}