#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?![0-9.,!?:;_|+\-*\\/=%°@&#§$"'`¨^ˇ()\[\]<>{}])[\S])+$"
Local $sString = "Vit5" & @CRLF & _
"V.it" & @CRLF & _
".Vit" & @CRLF & _
"Vit." & @CRLF & _
"Vit\\" & @CRLF & _
"V|it" & @CRLF & _
"Vi-t" & @CRLF & _
"V+it" & @CRLF & _
"+Vit" & @CRLF & _
"Vit^" & @CRLF & _
"V^it" & @CRLF & _
"V&it" & @CRLF & _
"Vi#t" & @CRLF & _
"Vi@t" & @CRLF & _
"Vit " & @CRLF & _
" Vit" & @CRLF & _
"V it" & @CRLF & _
"Vi)t" & @CRLF & _
"V(it" & @CRLF & _
"Vi[t" & @CRLF & _
"Vi]t" & @CRLF & _
"V?it" & @CRLF & _
"V!it" & @CRLF & _
"V$it" & @CRLF & _
"V*it" & @CRLF & _
"Vi{t" & @CRLF & _
"Vi}t" & @CRLF & _
"V<it" & @CRLF & _
"Vi>t" & @CRLF & _
"Vi_t" & @CRLF & _
"V-it" & @CRLF & _
"Vi=t" & @CRLF & _
"Vi%t" & @CRLF & _
"ˇVit" & @CRLF & _
"V;it" & @CRLF & _
"V\"it" & @CRLF & _
"V'it" & @CRLF & _
"V§t" & @CRLF & _
"V¨t" & @CRLF & _
"V`t" & @CRLF & _
"" & @CRLF & _
"Dopita" & @CRLF & _
"Václav" & @CRLF & _
"Átos" & @CRLF & _
"Čeněk" & @CRLF & _
"Pačáp" & @CRLF & _
"Ďurica" & @CRLF & _
"Naďa" & @CRLF & _
"Rémi" & @CRLF & _
"Zdeněk" & @CRLF & _
"Vít" & @CRLF & _
"Ľudovít" & @CRLF & _
"Ňouma" & @CRLF & _
"Ňuňu" & @CRLF & _
"Lórenc" & @CRLF & _
"Ópava" & @CRLF & _
"Mótovidlo" & @CRLF & _
"Řeřicha" & @CRLF & _
"Šušinka" & @CRLF & _
"Ťaťak" & @CRLF & _
"Úlehlú" & @CRLF & _
"Ůlehlů" & @CRLF & _
"Ýtý" & @CRLF & _
"Žežulka"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")