import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?![0-9.,!?:;_|+\\-*\\\\/=%°@&#§$\"'`¨^ˇ()\\[\\]<>\\{\\}])[\\S])+$";
final String string = "Vit5\n"
+ "V.it\n"
+ ".Vit\n"
+ "Vit.\n"
+ "Vit\\\\\n"
+ "V|it\n"
+ "Vi-t\n"
+ "V+it\n"
+ "+Vit\n"
+ "Vit^\n"
+ "V^it\n"
+ "V&it\n"
+ "Vi#t\n"
+ "Vi@t\n"
+ "Vit \n"
+ " Vit\n"
+ "V it\n"
+ "Vi)t\n"
+ "V(it\n"
+ "Vi[t\n"
+ "Vi]t\n"
+ "V?it\n"
+ "V!it\n"
+ "V$it\n"
+ "V*it\n"
+ "Vi{t\n"
+ "Vi}t\n"
+ "V<it\n"
+ "Vi>t\n"
+ "Vi_t\n"
+ "V-it\n"
+ "Vi=t\n"
+ "Vi%t\n"
+ "ˇVit\n"
+ "V;it\n"
+ "V\\\"it\n"
+ "V'it\n"
+ "V§t\n"
+ "V¨t\n"
+ "V`t\n\n"
+ "Dopita\n"
+ "Václav\n"
+ "Átos\n"
+ "Čeněk\n"
+ "Pačáp\n"
+ "Ďurica\n"
+ "Naďa\n"
+ "Rémi\n"
+ "Zdeněk\n"
+ "Vít\n"
+ "Ľudovít\n"
+ "Ňouma\n"
+ "Ňuňu\n"
+ "Lórenc\n"
+ "Ópava\n"
+ "Mótovidlo\n"
+ "Řeřicha\n"
+ "Šušinka\n"
+ "Ťaťak\n"
+ "Úlehlú\n"
+ "Ůlehlů\n"
+ "Ýtý\n"
+ "Žežulka";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}