using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?![0-9.,!?:;_|+\-*\\/=%°@&#§$""'`¨^ˇ()\[\]<>{}])[\S])+$";
string input = @"Vit5
V.it
.Vit
Vit.
Vit\\
V|it
Vi-t
V+it
+Vit
Vit^
V^it
V&it
Vi#t
Vi@t
Vit
Vit
V it
Vi)t
V(it
Vi[t
Vi]t
V?it
V!it
V$it
V*it
Vi{t
Vi}t
V<it
Vi>t
Vi_t
V-it
Vi=t
Vi%t
ˇVit
V;it
V\""it
V'it
V§t
V¨t
V`t
Dopita
Václav
Átos
Čeněk
Pačáp
Ďurica
Naďa
Rémi
Zdeněk
Vít
Ľudovít
Ňouma
Ňuňu
Lórenc
Ópava
Mótovidlo
Řeřicha
Šušinka
Ťaťak
Úlehlú
Ůlehlů
Ýtý
Žežulka";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}