import Foundation
let pattern = #""key"[ :]+((?=\[)\[[^]]*\]|(?=\{)\{[^\}]*\}|\"[^"]*\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{"level":" Warning","message":"Invalid argument supplied for foreach() in /deploy/producao/sigesp-sad/application/views/scripts/recursos/visualizacaorecurso.phtml on line 70","ugcs_servidor":"172.29.1.154","ugcs_ambiente":"producao","ugcs_aplicacao":"sigesp-sad","ugcs_node":"04"}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}