re = /"key"[ :]+((?=\[)\[[^]]*\]|(?=\{)\{[^\}]*\}|\"[^"]*\")/
str = '{"level":" Warning","message":"Invalid argument supplied for foreach() in /deploy/producao/sigesp-sad/application/views/scripts/recursos/visualizacaorecurso.phtml on line 70","ugcs_servidor":"172.29.1.154","ugcs_ambiente":"producao","ugcs_aplicacao":"sigesp-sad","ugcs_node":"04"}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end