const regex = /"key"[ :]+((?=\[)\[[^]]*\]|(?=\{)\{[^\}]*\}|\"[^"]*\")/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"key"[ :]+((?=\\[)\\[[^]]*\\]|(?=\\{)\\{[^\\}]*\\}|\\"[^"]*\\")', '')
const str = `{"level":" Warning","message":"Invalid argument supplied for foreach() in /deploy/producao/sigesp-sad/application/views/scripts/recursos/visualizacaorecurso.phtml on line 70","ugcs_servidor":"172.29.1.154","ugcs_ambiente":"producao","ugcs_aplicacao":"sigesp-sad","ugcs_node":"04"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}