use strict;
my $str = '{"level":" Warning","message":"Invalid argument supplied for foreach() in /deploy/producao/sigesp-sad/application/views/scripts/recursos/visualizacaorecurso.phtml on line 70","ugcs_servidor":"172.29.1.154","ugcs_ambiente":"producao","ugcs_aplicacao":"sigesp-sad","ugcs_node":"04"}';
my $regex = qr/"key"[ :]+((?=\[)\[[^]]*\]|(?=\{)\{[^\}]*\}|\"[^"]*\")/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}