using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""key""[ :]+((?=\[)\[[^]]*\]|(?=\{)\{[^\}]*\}|\""[^""]*\"")";
string input = @"{""level"":"" Warning"",""message"":""Invalid argument supplied for foreach() in /deploy/producao/sigesp-sad/application/views/scripts/recursos/visualizacaorecurso.phtml on line 70"",""ugcs_servidor"":""172.29.1.154"",""ugcs_ambiente"":""producao"",""ugcs_aplicacao"":""sigesp-sad"",""ugcs_node"":""04""}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}