re = /^([A-Za-z ][0-9](\\([A-Za-z]+\\))(\\([0-9]+\\))([@|\\-|'|\/| |.| |]|&|#|@ |(|) )*)/
str = 'krishna@123'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result