use strict;
my $str = 'krishna@123';
my $regex = qr/^([A-Za-z ][0-9](\\([A-Za-z]+\\))(\\([0-9]+\\))([@|\\-|'|/| |.| |]|&|#|@ |(|) )*)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";