const regex = /^([A-Za-z ][0-9](\\([A-Za-z]+\\))(\\([0-9]+\\))([@|\\-|'|/| |.| |]|&|#|@ |(|) )*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z ][0-9](\\\\([A-Za-z]+\\\\))(\\\\([0-9]+\\\\))([@|\\\\-|\'|\/| |.| |]|&|#|@ |(|) )*)', '')
const str = `krishna@123`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);