import Foundation
let pattern = #"<div[^>]*>((?:(?:(?!<div[^>]*>|<\/div>).)+|<div[^>]*>(?1)<\/div>)*)<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<div class="cls1">
Hello
<p></p>
<div id="id1">
Hi mohammad
</div>
<div></div>
</div>
<div class="cls1">
Hello
<p></p>
<div id="id1">
Hi mohammad
</div>
<div></div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)