using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div[^>]*>((?:(?:(?!<div[^>]*>|<\/div>).)+|<div[^>]*>(?1)<\/div>)*)<\/div>";
string input = @"<div class=""cls1"">
Hello
<p></p>
<div id=""id1"">
Hi mohammad
</div>
<div></div>
</div>
<div class=""cls1"">
Hello
<p></p>
<div id=""id1"">
Hi mohammad
</div>
<div></div>
</div>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}