#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<div[^>]*>((?:(?:(?!<div[^>]*>|<\/div>).)+|<div[^>]*>(?1)<\/div>)*)<\/div>"
Local $sString = "<div class="cls1">" & @CRLF & _
" Hello" & @CRLF & _
" <p></p>" & @CRLF & _
" <div id="id1">" & @CRLF & _
" Hi mohammad" & @CRLF & _
" </div>" & @CRLF & _
" <div></div>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="cls1">" & @CRLF & _
" Hello" & @CRLF & _
" <p></p>" & @CRLF & _
" <div id="id1">" & @CRLF & _
" Hi mohammad" & @CRLF & _
" </div>" & @CRLF & _
" <div></div>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")