const regex = /<div[^>]*>((?:(?:(?!<div[^>]*>|<\/div>).)+|<div[^>]*>(?1)<\/div>)*)<\/div>/isg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div[^>]*>((?:(?:(?!<div[^>]*>|<\\\/div>).)+|<div[^>]*>(?1)<\\\/div>)*)<\\\/div>', 'isg')
const str = `<div class="cls1">
Hello
<p></p>
<div id="id1">
Hi mohammad
</div>
<div></div>
</div>
<div class="cls1">
Hello
<p></p>
<div id="id1">
Hi mohammad
</div>
<div></div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}